<!DOCTYPE html><html class="en" lang="en" ng-app="app"><head class="ng-non-bindable"><meta charset="utf-8" /><title>ArtStation - Godzilla 3D artwork by Metin Seven</title>
<meta name="description" content="Godzilla 3D artwork by Metin Seven (concept: Riki Fuhrmann)" />
<meta name="keywords" content="godzilla, monster, dinosaur, city, rampage, cartoon, cartoony, cute, kawaii, fun, 3d, art, artwork, illustration, rendering, blender" />
<meta property="og:url" content="https://www.artstation.com/metinseven/blog/Rb84/godzilla-3d-artwork" />
<meta property="og:site_name" content="ArtStation" />
<meta property="og:title" content="Godzilla 3D artwork by Metin Seven" />
<meta property="og:image" content="https://cdna.artstation.com/p/media_assets/images/images/000/343/894/large/metin-seven_stylized-artistic-3d-illustrator_godzilla-monster-dinosaur-artwork.jpg?1543433028" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="1280" />
<meta property="og:description" content="Godzilla 3D artwork by Metin Seven (concept: Riki Fuhrmann)" />
<meta property="og:type" content="website" />
<meta property="fb:app_id" content="249255215230397" />
<meta name="twitter:site" content="@artstationhq" />
<meta name="twitter:site_name" content="ArtStation" />
<meta name="twitter:title" content="Godzilla 3D artwork by Metin Seven" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Godzilla 3D artwork by Metin Seven (concept: Riki Fuhrmann)" />
<meta name="twitter:image" content="https://cdna.artstation.com/p/media_assets/images/images/000/343/894/large/metin-seven_stylized-artistic-3d-illustrator_godzilla-monster-dinosaur-artwork.jpg?1543433028" />
<meta name="image" content="https://cdna.artstation.com/p/media_assets/images/images/000/343/894/large/metin-seven_stylized-artistic-3d-illustrator_godzilla-monster-dinosaur-artwork.jpg?1543433028" />
<meta name="robots" content="index" /><meta content="IE=Edge,chrome=1" http-equiv="X-UA-Compatible" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"c7d2c3241e","applicationID":"136863096","transactionName":"e1sMQhQNXApWRBsEW1dTPUYJEUQVHEVcCUA=","queueTime":0,"applicationTime":306,"agent":""}</script>
<script type="text/javascript">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</script><meta content="width=device-width, initial-scale=1.0" name="viewport" /><meta content="#000000" name="theme-color" /><meta content="#000000" name="msapplication-navbutton-color" /><meta content="#000000" name="apple-mobile-web-app-status-bar-style" /><meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="GdUccIVskELEJgDDm+9TPTF3uS7JLX/MKVgQ7KMZfrkAAoToITHhmVALKWIPyu37htvMrXasYa+z5Q43YjeoBg==" /><link rel="apple-touch-icon-precomposed" type="image/png" href="/assets/apple-touch-icon-72x72-precomposed-2a4f58d544ecd6791c76dd977c179641.png" sizes="72x72" /><link rel="apple-touch-icon-precomposed" type="image/png" href="/assets/apple-touch-icon-72x72-precomposed-2a4f58d544ecd6791c76dd977c179641.png" /><link rel="shortcut icon" type="image/x-icon" href="/assets/favicon-01f5c6ded851f792030eff4728764dcf.ico" /><link rel="alternate" type="application/rss+xml" title="Metin Seven on ArtStation" href="https://www.artstation.com/metinseven.rss" /><link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,400,300,600,700,800" /><link href="/opensearch.xml" rel="search" title="ArtStation" type="application/opensearchdescription+xml" /><script>!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window, document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '614550515641125');
fbq('track', 'PageView');</script><noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=614550515641125&ev=PageView&noscript=1"
/></noscript><link rel="stylesheet" media="all" href="/assets/application-45aedc1351fb7cefc0e8091e3f297593.css" /><script>environment = "production";
window.websocket_host = "https://ws.artstation.com"
window.images_host = "images.artstation.com"</script><script>window.api                         = {};
window.api.notifications           = {};
window.api.messaging               = {};
window.api.websockets              = {};
window.api.notifications.enabled   = true;
window.api.messaging.enabled       = true;
window.api.websockets.enabled      = true;</script><script>window.user_id = null;
window.user_show_adult = false;</script><script>window.currentUserData = {"csrf_token":"M3Zb8VAfFzRS/0UcgUahJLZ6bTUfwOhyowRHyaiZ8xcqocNp9EJm78bSbL0VYx/iAdYYtqBB9hE5uVkSabclqA=="};
window.currentUserAuthorizations = {"users_admin":false,"user_following_create":false,"user_block_create":false,"projects_admin":false,"project_create":false,"project_like":false,"project_comment_create":false,"project_comment_like":false,"project_comment_reply":false,"project_edit_visibility":false,"projects_mark_editor_pick":false,"projects_mark_mature_content":false,"projects_mark_suppressed":false,"challenge_announcements_admin":false,"challenge_announcement_like":false,"challenge_announcement_comment_create":false,"challenge_announcement_comment_like":false,"submissions_admin":false,"submission_like":false,"submission_updates_admin":false,"submission_update_create":false,"submission_update_like":false,"submission_update_comment_create":false,"submission_update_comment_like":false,"blog_posts_admin":false,"blog_post_create":false,"blog_post_like":false,"blog_post_comment_create":false,"blog_post_comment_like":false,"messages_admin":false,"messages_view":false,"message_create":false,"current_user_profile_view":false,"current_user_profile_edit":false,"current_user_username_edit":false,"current_user_email_edit":false,"current_user_password_edit":false,"current_user_resume_settings":false,"current_user_social_settings":false,"current_user_hiring_settings":false,"current_user_notification_settings":false,"current_user_messaging_settings":false,"current_user_upload_pdf_resume":false,"notifications_admin":false,"notifications_view":false,"activity_admin":false,"activity_view":false,"collections_admin":false,"collections_view":false,"collection_create":false,"collection_project_add":false,"jobs_admin":false,"job_create":false,"products_admin":false,"product_create":false,"analytics_admin":false,"analytics_view":false,"pro_subscriptions_admin":false,"abuse_reports_admin":false,"abuse_report_create":false,"website_builder_customize_theme":false,"website_builder_publish_pro_theme":false,"website_builder_edit_pro_settings":false,"website_builder_create_page":false,"website_builder_password_protect_page":false,"albums_admin":false,"albums_view":false,"album_create":false,"album_project_add":false,"album_edit_visibility":false};</script><script>window.upload_config = {
  maxImageSize: 10485760,
  maxMarmosetFileSize: 15728640,
  maxPdfFileSize: 20971520,
  maxPanoFileSize: 10485760
};</script><script>window.angular_debug_enabled = false;
window.locale = "en";
I18n = {}
I18n.defaultLocale = "en";
I18n.locale = "en";
window.artstation_config = {
  preloaded_feed_comments_count: 5,
  preloaded_challenge_announcement_replies_count: 5
};</script><script src="/assets/libs-fac5711e295bbeb43d5a3a3f559d5b10.js"></script><script src="/assets/application-b955be9cf465b9de432b72f3232efa38.js"></script><script src="/assets/community-a9bdbc8939984a4f54b03fd7c1cfeff4.js"></script><meta content="app-id=924645286" name="apple-itunes-app" /><meta content="app-id=com.ballistiq.artstation" name="google-play-app" />
<script type="text/javascript">
_atrk_opts = { atrk_acct:"jzg4k1a0Sn00Ua", domain:"artstation.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=jzg4k1a0Sn00Ua" style="display:none" height="1" width="1" alt="" /></noscript>
 <base href="/" /></head><body class="{{$root.bodyClass}} {{$root.additionalBodyClasses}}"><div id="fb-root"></div><div id="top"></div><div class="wrapper"><nav class="navbar navbar-inverse navbar-static-top" id="main-nav" role="navigation"><div class="navbar-header"><a aria-expanded="false" class="nav-button collapsed visible-xs visible-sm" data-target="#main-menu-left" data-toggle="collapse" href="#"><div class="line"></div><div class="line"></div><div class="line"></div></a><div class="nav-button-right"><a target="_self" class="btn btn-primary btn-sm" href="/users/sign_in">Sign in</a></div><a class="navbar-brand" href="/" target="_self"><img class="logo hidden-md" width="122" height="22" alt="ArtStation" src="/assets/logo-46e5ec7d59ee00506e0f633f4c3ddc65.svg" /><img class="icon visible-md" width="25" height="22" alt="ArtStation" src="/assets/logo-icon-7b192dc9824a7e8cb9f0cada7e9eb6ab.svg" /></a></div><div id="main-menu"><ul class="nav navbar-nav collapse navbar-collapse" id="main-menu-left"><li><a target="_self" href="/about">About</a></li><li><a target="_self" href="/marketplace">Marketplace</a></li><li><a target="_self" href="/jobs">Jobs</a></li><li><a target="_self" href="/contests">Challenges</a></li><li><a target="_self" href="https://magazine.artstation.com">Magazine</a></li><li><a target="_self" href="/blogs">Blogs</a></li><li class="more"><a class="dropdown-toggle" data-toggle="dropdown" href="#"><span>More</span><i class="far fa-chevron-down fa-fw fa-pad-left"></i></a><ul class="dropdown-menu"><li><a target="_blank" href="https://www.artstationmedia.com"><i class="far fa-books fa-fw fa-pad-right"></i>Books</a></li><li><a target="_blank" href="https://www.artstationmasterclasses.com"><i class="far fa-bolt fa-fw fa-pad-right"></i>MasterClasses</a></li></ul></li><li class="books"><a target="_blank" class="books" href="https://www.artstationmedia.com">Books</a></li><li class="masterclasses"><a target="_blank" class="masterclasses" href="https://www.artstationmasterclasses.com">MasterClasses</a></li><li class="visible-xs visible-sm visible-md"><a target="_self" class="visible-xs visible-sm visible-md" href="/search">Search</a></li><li class="visible-xs visible-sm"><a target="_self" class="visible-xs visible-sm" href="/marketplace/cart">My Cart<span class="badge badge-cart-items hidden" data-cart-counter="true">0</span></a></li><li class="visible-xs visible-sm"><span><a target="_self" class="btn btn-primary btn-sm" href="/registration/signup"><i class="far fa-pen-square fa-pad-right"></i>Sign up</a><a target="_self" class="btn btn-primary btn-sm" href="/users/sign_in"><i class="far fa-sign-in fa-pad-right"></i>Sign in</a></span></li><li class="visible-xs visible-sm misc-dropdown"><a aria-expanded="false" class="dropdown-toggle" data-toggle="dropdown" href="#">More<i class="far fa-chevron-down fa-pad-left"></i></a><ul class="dropdown-menu"><li><a target="_self" href="/about"><i class="icon icon-artstation fa-fw fa-pad-right"></i>About ArtStation</a></li><li><a target="_self" href="/about/marketing-services"><i class="far fa-star fa-fw fa-pad-right"></i>Marketing Services</a></li><li class="divider"></li><li><a target="_blank" href="https://support.artstation.com"><i class="far fa-question fa-fw fa-pad-right"></i>Help</a></li><li class="divider"></li><li><a target="_blank" href="http://eepurl.com/JF5iP"><i class="far fa-envelope fa-fw fa-pad-right"></i>Newsletter</a></li><li><a target="_blank" href="https://www.facebook.com/artstationhq"><i class="fab fa-facebook-f fa-fw fa-pad-right"></i>Facebook</a></li><li><a target="_blank" href="https://www.instagram.com/artstationhq"><i class="fab fa-instagram fa-fw fa-pad-right"></i>Instagram</a></li><li><a target="_blank" href="https://twitter.com/ArtStationHQ"><i class="fab fa-twitter fa-fw fa-pad-right"></i>Twitter</a></li><li class="divider"></li><li><a target="_self" href="/tos"><i class="far fa-gavel fa-fw fa-pad-right"></i>Terms of Service</a></li><li><a target="_self" href="/privacy"><i class="far fa-lock fa-fw fa-pad-right"></i>Privacy Policy</a></li></ul></li><form class="navbar-form navbar-left navbar-search visible-lg" role="search"><div class="form-group"><input class="form-control" id="search-input" placeholder="Search" type="search" /></div></form></ul><ul class="nav navbar-nav navbar-right collapse navbar-collapse" id="main-menu-right"><li><a target="_self" href="/marketplace/cart"><i class="far fa-shopping-cart fa-lg"></i><span class="badge badge-cart-items hidden" data-cart-counter="true">0</span></a></li><li><a target="_self" href="/registration/signup"><i class="far fa-pen-square fa-pad-right"></i>Sign up</a></li><li><div class="navbar-btn"><a target="_self" data-toggle="modal" data-target="#login-modal" class="btn btn-primary sign-in-button" data-remote="true" href="/users/sign_in"><i class="far fa-sign-in fa-pad-right"></i>Sign in</a></div></li><li class="dropdown hidden-xs hidden-sm"><a aria-expanded="false" class="dropdown-toggle misc-dropdown" data-toggle="dropdown" href="#"><i class="far fa-ellipsis-v fa-lg"></i></a><ul class="dropdown-menu"><li><a target="_self" href="/about"><i class="icon icon-artstation fa-fw fa-pad-right"></i>About ArtStation</a></li><li><a target="_self" href="/about/marketing-services"><i class="far fa-star fa-fw fa-pad-right"></i>Marketing Services</a></li><li class="divider"></li><li><a target="_blank" href="https://support.artstation.com"><i class="far fa-question fa-fw fa-pad-right"></i>Help</a></li><li class="divider"></li><li><a target="_blank" href="http://eepurl.com/JF5iP"><i class="far fa-envelope fa-fw fa-pad-right"></i>Newsletter</a></li><li><a target="_blank" href="https://www.facebook.com/artstationhq"><i class="fab fa-facebook-f fa-fw fa-pad-right"></i>Facebook</a></li><li><a target="_blank" href="https://www.instagram.com/artstationhq"><i class="fab fa-instagram fa-fw fa-pad-right"></i>Instagram</a></li><li><a target="_blank" href="https://twitter.com/ArtStationHQ"><i class="fab fa-twitter fa-fw fa-pad-right"></i>Twitter</a></li><li class="divider"></li><li><a target="_self" href="/tos"><i class="far fa-gavel fa-fw fa-pad-right"></i>Terms of Service</a></li><li><a target="_self" href="/privacy"><i class="far fa-lock fa-fw fa-pad-right"></i>Privacy Policy</a></li></ul></li></ul></div></nav><div class="wrapper-main"><template id="templateNotices" style="display:none"></template><div class="notices"></div><script>const container = document.getElementsByClassName('notices')[0]
const template = document.getElementById('templateNotices')
// template works like div in ie11, that's why we need display:none and absence of .content
const notices = (template.content || template).querySelectorAll('.notice')

container.innerHTML = ''
for (let i = 0, il = notices.length; i < il; i++) {
  container.appendChild(notices[i].cloneNode(true))
}</script><script>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</script><div ng-view=""></div></div></div><div class="modal fade" id="login-modal"><div class="modal-dialog"><div class="modal-content"><div class="modal-header"><button aria-hidden="true" class="close" data-dismiss="modal" type="button"><i class="far fa-times"></i></button><h3 class="modal-title">Sign In</h3></div><div class="modal-body"><form class="simple_form new_user" id="new_user" action="/users/sign_in" accept-charset="UTF-8" method="post"><input name="utf8" type="hidden" value="&#x2713;" /><input type="hidden" name="authenticity_token" value="2ls6zxgChj2Fo1pVbEt/GIZaWwoa+Cyy5X9A1w3u4LDDjKJXvF/35hGOc/T4bsHeMfYuiaV5MtF/wl4MzMA2Dw==" /><input name="user_return_to" ng-value="location.path()" type="hidden" /><div class="form-group email optional user_email"><label class="control-label email optional" for="user_email">Your email</label><input class="form-control string email optional" autofocus="autofocus" placeholder="email@example.com" type="email" name="user[email]" id="user_email" /></div><div class="form-group password optional user_password"><label class="control-label password optional" for="user_password">Password</label><input class="form-control password optional" autocomplete="off" placeholder="password" type="password" name="user[password]" id="user_password" /></div><div class="form-group hidden user_remember_me"><input class="form-control hidden" type="hidden" value="true" name="user[remember_me]" id="user_remember_me" /></div><div class="form-group"><button name="button" type="submit" class="btn btn-default"><i class="far fa-sign-in fa-pad-right"></i>Sign in</button></div><div class="row row-flex"><div class="col-xs-6"><a target="_self" href="/users/password/new">Forgot password?</a></div><div class="col-xs-6 text-right"><a target="_self" href="/registration/signup">Sign up</a></div></div><hr /><a class="btn btn-default" target="_self" href="/users/auth/facebook"><i class="fab fa-facebook fa-pad-right"></i>Sign in with Facebook</a></form></div></div></div></div><div class="modal fade" id="announcement-modal"><div class="modal-dialog"><div class="modal-content"><div class="modal-header"><button aria-hidden="true" class="close" data-dismiss="modal" type="button"><i class="far fa-times"></i></button><h3 class="modal-title" data-title=""></h3></div><div class="modal-body"><a href=""><img data-image="" src="" width="100%" /></a><div class="separator-sm"></div><div data-body=""></div></div><div class="modal-footer"><a class="btn" data-action="open"></a><a class="btn btn-default pull-right" data-action="close">Close</a></div></div></div></div><script id="hover-card" type="text/template"><div class="hover-card" hidden=""><a class="hover-card-image" ng-href="{{ user.permalink }}"><img alt="{{ user.full_name }}" height="106" ng-if="user.small_cover_url" ng-src="{{ user.small_cover_url }}" width="323" /><img alt="{{ user.full_name }}" height="106" ng-if="user.default_cover_url" ng-src="{{ user.default_cover_url }}" width="323" /></a><a class="hover-card-avatar" ng-href="{{ user.permalink }}"><img class="img-circle img-responsive" height="60" ng-src="{{ user.medium_avatar_url }}" width="60" /></a><div class="hover-card-name"><a ng-bind-html="trustAsHtml(user.full_name)" ng-href="{{ user.permalink }}"></a><a class="pro-badge smaller" href="/pro" ng-if="user.pro_member" target="_top">PRO</a><div class="staff-badge smaller" ng-if="user.is_staff">STAFF</div></div><div class="hover-card-headline" ng-bind-html="trustAsHtml(user.headline)"></div><div class="hover-card-following" ng-if="user.following_back">Follows you</div><div class="hover-card-grid" ng-show="projects.length != 0"><a class="{{ project.isEmptyProject ? &#39;hover-card-grid-item-empty&#39; : &#39;hover-card-grid-item&#39; }}" ng-href="{{ project.isEmptyProject ? &#39;&#39; : &#39;/artwork/&#39; + project.hash_id }}" ng-repeat="project in projects track by $index"><div class="far fa-image" ng-if="project.isEmptyProject"></div><img alt="" height="115" ng-class="{ &#39;img-blur&#39; : project.hide_as_adult }" ng-if="!project.isEmptyProject" ng-src="{{ ::project.cover.micro_square_image_url }}" width="115" /><div class="mature-content-label" ng-if="::project.hide_as_adult">Mature content</div></a></div><div class="hover-card-meta"><div class="hover-card-meta-inner"><div class="hover-card-meta-info"><as-pluralize count="user.followers_count" counter-class="text-white" dict="counters.followers"></as-pluralize></div><div class="hover-card-meta-info"><as-pluralize count="user.projects_likes_count" counter-class="text-white" dict="counters.likes"></as-pluralize></div><div class="hover-card-meta-info"><as-pluralize count="user.project_views_count" counter-class="text-white" dict="counters.views"></as-pluralize></div></div><div class="hover-card-meta-following"><follow-button small="true" user="user"></follow-button></div></div></div></script><script>window.flashes = {};</script><script>(function() {
  $(function() {
    return $.each(window.flashes, function(type, content) {
      if (!content) {
        return;
      }
      if (type === "error") {
        return Flash.error(content);
      } else {
        return Flash.notice(content);
      }
    });
  });

}).call(this);
</script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-29038430-1"></script>
<script>
  window.google_analytics_id = 'UA-29038430-1';
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

</script><script>
  window.fbAsyncInit = function() {
    FB.init({
      appId            : '249255215230397',
      autoLogAppEvents : true,
      xfbml            : true,
      version          : 'v3.1'
    });
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "https://connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<script type="text/javascript" src="//assets.pinterest.com/js/pinit.js" async defer></script><script>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</script></body></html>